Installer Woes

Mike Matthews - Omnis omnis at
Sun Jan 14 19:17:59 UTC 2024

Excellent news :)

Mike Matthews

Lineal Software Solutions
Commercial House, The Strand<x-apple-data-detectors://1/1> Barnstaple, Devon, EX31 1EU<x-apple-data-detectors://1/1>

omnis at<mailto:mike.matthews at><><>

On 14 Jan 2024, at 17:59, Das Goravani <goravanis at<mailto:goravanis at>> wrote:

Caution: This is a message which has originated from outside the organisation. Ensure the sender is trusted and the content is safe before opening links or attachments.

Good News: I installed the latest Inno Setup Script Studio and remade my installer and this time it copied into the installer ALL the files that make up Omnis. Previously it was only doing some.

It still has the problem of putting the exe main folder into Program Files x86 instead of just Program Files/Omnis Software…

It doesn’t run right from there. I moved it after installation into Program Files/Omnis Software/Jyotish Studio 7.5/ and then it worked.

So I have to wrangle with the script in order to get it to do that.

They have this shortcut.  {app}.   That the script studio inserts for the path to the installed app.  That is wrong because it is putting it in x86

So just now I hardwired the destination to be Program Files\Omnis Software\Jyotish Studio 7.5\

I am compiling it right now,

Then I will run it and see if my changes work.

That’s where I’m at right now.

I’m hoping that my hardwiring of the destination folder works.  I am not that savvy with Inno Script Studio but I am learning.

It’s really a very powerful and nice Setup Installer Making Program and it’s free.

I tried Advanced Installer yesterday but was put off by their price.. $399 a year or $599 perpetual.  That’s too much for little old me.

Their program I used in demo free mode yesterday and it too put Omnis into the x86 folder from where it does not link to the AppData folder correctly and so you get all kinds of errors upon launch and then it just doesn’t run.

This is all very strange because Inno Script Studio has always worked before. I have made a number of Windows installers with it and it always previously put Omnis folder into Program Files\Omnis Software correctly and everything ran.  This time, it had the bugs of not including all files and folders and putting the program into x86 instead. So I am working out those two bugs.

The reinstall of Inno Script Studio seems to have handled the inclusion bug.

Now I am waiting to see if my hard coded destination path works.  We’ll see in just a few minutes.

Typing Later Now…

It worked !!!  I now have a new Windows Installer that works !!!

I’m happy now..

Das Goravani
Manage your list subscriptions at
Start a new message -> mailto:omnisdev-en at

More information about the omnisdev-en mailing list