How to do Notarization Now Nov 1 23 Sonoma

alan at goconnected.com alan at goconnected.com
Thu Nov 2 19:54:06 UTC 2023


Das,

Maybe try using an app like BatChmod to strip out the detritus. I think the "Clear xattrs" switch does that. I've been using that app for years (thanks to my partner Scott Archer) to prep the package and other files for code signing/DMG creation.

I've never had an issue with code signing although I've been struggling to notarize since moving my app to Studio 10.22. But I haven't tried with notarytool yet so I'll be giving that a try soon.

-Alan


> On Nov 1, 2023, at 7:51 AM, Das Goravani <goravanis at gmail.com> wrote:
> 
> 
> Well today I tried using the commands I gave in previous post on this subject and encountered errors. 
> 
> When trying to code sign my app, on the third command it came back with "detritus not allowed". 
> 
> I was able to code sign using these code sign commands on Catalina, on a virtual machine I have. Something about these code sign commands works on Catalina with an older XCODE but not on the current OS with the latest XCODE. 
> 
> So I signed my app on Catalina. I then tried to run the "store credentials" command.
> 
> I got an error on that which I can’t figure out, which I made another post about today you can see. 
> 
> So I’m stuck on store credentials. I wrote to "Quinn the Eskimo" at Apple Developer Support. Hopefully he will get back to me with some help. 
> 
> Das
> _____________________________________________________________
> Manage your list subscriptions at https://lists.omnis-dev.com
> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 



More information about the omnisdev-en mailing list