JS Form File Weirdness

Das Goravani goravanis at gmail.com
Thu Mar 23 20:26:10 UTC 2023


This line of code is from the Omnis example. I didn’t change a thing.

Do $cinst.$objs.JSFormFile.$action.$assign(kJSFileActionDownload)

It should not say "Notation not supported on it"

It is IN the remote form, in a class method. That is where it is in the demo.

I am using the exact line of code from the demo, and it worked up til now.

What changed is this:

$pdfcomplete is a task method, so when that fires you are OUTSIDE of your remote form.

So what I did I set it up to call back to my form.

With a ref I call a method back in my form.

That method calls the above line of code. 

So the fact that the Method Stack has in it that we were just in the task, calling from the task.. to the forms method.. is that why it’s having problems?

I wouldn’t think so.

I am running code in the form which has the JSFormFile on it. 

This code worked yesterday. I only rearranged a few methods today. It should not have blown up. 

Any ideas?




More information about the omnisdev-en mailing list