Do Shell Script to unzip on M1 Mac with spaces in path name

Mike Matthews - Omnis omnis at
Mon Nov 28 17:39:17 UTC 2022

Bingo!  Thank you Kelly, I thought I had tried that as well, but clearly not.  Maybe did both, who knows when you have spent hours doing all sorts of options.

So stick the path inside single quotes is the answer.

Mike Matthews

Lineal Software Solutions
Commercial House, The Strand<x-apple-data-detectors://1/1> Barnstaple, Devon, EX31 1EU<x-apple-data-detectors://1/1>

omnis at<mailto:mike.matthews at><><>

On 28 Nov 2022, at 13:43, Kelly Burgess <kellyb at<mailto:kellyb at>> wrote:

Caution: This is a message which has originated from outside the organisation. Ensure the sender is trusted and the content is safe before opening links or attachments.

Hi Mike,

I have tried escaping the spaces with %20, single \ and double \\, all to no joy.

Try this - enclose the path in single quotes using un-escaped spaces...

Begin text block
Text: {cd '/Users/mike/Library/Application Support/SQLWorks/SQLWorks v10221-31840 Dev/Lineal SQLWorks Startup/Lineal SQLWorks Folder'}
Text: {; unzip -o,1,NS-RmaCiKLv2dzZsjiwL-s93UVfkcMzM5trfovpECJWznlPipHYBhPHoCrO3CeYbgB-9vpL70hBQv6e-R21_mAeap3ApehZOdeIoMoJ-cQ,,&typo=1}
End text block
Get text block cmdLine

Begin text block
Text: {do shell script "[cmdLine]"}
End text block
Get text block script

Do $root.$runapplescript(script,result,error)
If error<>''
 # handle error...
End if

Manage your list subscriptions at,1,HlM9BurythG2ZZvNx6DJZGK8B6MBXaPXa1a24-UfBNf6XwdOiuvT9aLK3ouSkRDJEvUJ6FCTmF6AZR8y34NcLymDJF_uWgYRRhMUKBh7L7-AD8MgpA,,&typo=1
Start a new message -> mailto:omnisdev-en at

More information about the omnisdev-en mailing list