Various weird problems with server

Das Goravani goravanis at
Sat Mar 5 03:24:52 UTC 2022

This is a jump from another thread, it’s taken a new turn.

My situation is 

I have 4 websites I want to get SSL certificates for
I am real familiar with the process, it’s easy

I use MAMP.. to manage the serving of the websites, it manages Apache

In fact it installs it’s own Apache
There is an Apache that comes with the Mac also installed

My certificate, which I just got the other day, is failing, Chrome says there’s an error in it
So I am going ahead and trying to get a new one

This was going smoothly the other day,  nothing has changed since then
Now when I try to get this new cert from Certbot it says

Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

My server was working beautifully at first when I fixed it yesterday

Now apache won’t start in MAMP, suddenly

And about the above message, hear me out on this:

MAMP offers a file called HTTPD_VHOSTS as one of the config files located in a folder called EXTRA inside of MAMP’s folder. That’s not the normal name of the vhosts file, it’s just vhosts normally.  I get a sense that MAMP doesn’t use this file. I get a sense that MAMP uses the VHOST file of the apache that comes with the Mac. Because I think, various other apps look for that file in that place, not in MAMPS folder. 

Nevertheless, I have filled out the VHOST file that MAMP offers in their folder. I placed entries for my four websites there.

That was years ago and things worked fine for years. Secure, all four, one cert, MAMP had no competition when launching.

Now, when I launch it, it says /sbin/LaunchPD is blocking port 80

That has never happened before. I rebooted and it’s still happening. 

Why did the server work so well for a day, nothing has changed, and now that Lanchd thing is back. What do I do about that?

And if certbot says nobody is listening on port 80, setup a VHOST.. HOW do I convince it that I have VHOSTS entered into MAMP for one, that usually suffices, however it does it, it must write them to some vhosts file that is used, usually works, usually can get certificates

This is wrong, it’s as if there is a hardware problem

It changes by itself, gives problems that were never given before suddenly when I did nothing

I thought I had my server problems solved

So my questions are

Where do you think my vhosts file is? Which one is certbot looking at?
Why would it never have this complaint before?
Maybe my server has to be up for their to be a vhost file in place, and right now it’s gone down again, maybe in other words MAMP needs to be running for certbot to work? That doesn’t make sense. 

Where is the vhost file that comes with the Mac if you know. 

When my sites are usually being served and working, why would it say “can’t find any vhost on port 80” (maybe my sites were down when it said this, but I doubt I need to have MAMP running when making certs, but certs is looking for the vhost file.. I have not filled out the one that comes with the Mac, only the one that comes with MAMP. Which certbot obviously isn’t reading, it doesn’t know about it is my guess, if I find out where vhosts is located, I will copy what I have in MAMP’s to the other one. That might satisfy certbot. 

According to tutorial on web, you should be able to issue cert command, get cert, tell MAMP where it is, and it will work. 

I was able to do this yesterday. For 2 sites out of four. Two still gave “insecure” warnings when they should not have. That was ALL that was wrong. MAMP was starting, launching apache, nothing was blocking, and the cert worked for 2, 

Now MAMP can’t launch Apache, port 80 is being blocked by launchd whatever that is, so I can’t launch the web server, and I can’t get a new cert, because

It can’t find vhosts listening to port 80

It says I should set up my vhosts file

And, when I opt for “file in folder” type of validation instead, it says

That the Webroot of one of my sites isn’t a folder.. and yet it is, I have the path right, it is a directory, it has files in it, it is serving those files, or was serving them

So I’m being told GARBAGE

THAT’S what makes me say “It’s as if there’s a hardware problem”. 

Because it is coming up with multiple garbages, new things happening when I changed nothing, multiple weird things suddenly happening. It being OK for a day, then spontaneously going downhill all by itself.. 

I’m at a loss again, I feel like I’m going in circles, like I can’t fix one, so I can’t fix the other, as they’re linked it seems.. 

What’s weird too is that the other apache was launching over and over blocking MAMP from being able to start IT’S apache, that was one period about a week ago.. then it stopped doing that, all by itself, I had run the stop command on it a few times, but that’s not permanent, yet never lately do I get that that apache is blocking port 80 like I was getting

Now I’m getting that launchd is blocking port 80

What do I do about any of this?

Whats the most weird is certbot telling me that that site has an invalid document root.. that is totally not true, it is a valid directory, so that is pure voodoo and makes me desperate, because you can’t work with a system that doesn’t know it’s own basics straight up correct

I’m desperate all over again now, thought I had a good cert, and server running no problems, but I don’t have that.. my sites are down, which probably means my mail is too but I haven’t checked, this all makes me desperate. I’m doing what worked for years. I have not upgraded the system software or installed any major new thing. 

Thanks for helping with anything,


More information about the omnisdev-en mailing list