FW: Postgres 14, libpq and scram

Chris Hughes ataddata at bigpond.net.au
Thu Jun 30 01:01:19 UTC 2022


Hi Doug and Joe

 

The version I was using was Postgres 12.9

The version I asked to be install on Kubuntu 22.04 was 14.4 as detailed there are issues with 14.3    . 

However when I look a the internal details from the Postgres the version is 14.00.03, this is case you do not always get what you want

 

Will give changing libpg.dll  a try.

 

Will also give the DAM angle a try, one at time to see what the solution is.

 

Thanks for your response's

 

 

 

From: Doug Easterbrook [mailto:doug at artsman.com] 
Sent: Thursday, 30 June 2022 2:28 AM
To: OmnisDev List - English
Cc: ataddata at bigpond.net.au
Subject: Re: Postgres 14, libpq and scram

 

hi Chris.

 

you didn’t say what version of postgres you were using before you installed 14.3.    

 

There was a change to the password hashing from MD5 to scram-sha-256 (more secure).   The pg_hba.conf is likely set up to be scram-sha-256.

 

if you change PG_HBA.con to TRUST, reload the PG config, and attempt a connection, if it works, then you know the libpq.dll is too old to support scram authentication. 

 

thats the first place I’d start.       

 

 

we are using Postgres 14 with studio 10.2 and I I’ve updated our libpq.dll to the one that comes with postgres 11 — the version number on the libpq.dll is 11.2.1492.    I have also got this paired with changes to allow connection with TLS 1.2 and scram authentication.

 

if you want it, I can give you those 5 dll’s to drop into the omnis tree.    but do try removing  scram from the PGAhba to see if you are successful first.

 

 

 

 

 

Side note:   you should update to postgres 14.4 — there is a potential b-tree index issue with postgres 14.0 to 14.3.

 

from postgresql.org web site

 

2022-06-16 -  <https://www.postgresql.org/about/news/postgresql-144-released-2470/> PostgreSQL 14.4 Released!

The PostgreSQL Global Development Group has  <https://www.postgresql.org/about/news/postgresql-144-released-2470/> released PostgreSQL 14.4 to fix an issue that could cause silent data corruption when using the  <https://www.postgresql.org/docs/current/sql-createindex.html> CREATE INDEX CONCURRENTLY or  <https://www.postgresql.org/docs/current/sql-reindex.html> REINDEX CONCURRENTLYcommands. Please see the  <https://www.postgresql.org/about/news/postgresql-144-released-2470/> release announcement for information on how to detect and correct silent data corruption in your indexes.

This release also fixes over 15 bugs since PostgreSQL 14.3 was released in May. For the full list of changes, please review the  <https://www.postgresql.org/docs/release/> release notes.

 


Doug Easterbrook

Arts Management Systems Ltd.

mailto:doug at artsman.com

http://www.artsman.com

Phone (403) 650-1978





On Jun 27, 2022, at 7:30 PM, Chris Hughes <ataddata at bigpond.net.au> wrote:

 

Greetings one and all,

After days of searching for a fault, I went back to basics to solve the
problem and what surfaced when I installed  Postgres 14.3 and the normal
Omnis 6.3 application would not work.

Operating System :- Kubuntu 22.04 

Omnis Application Studio 6.3 

When looking further I found the $hostname was not being calculated from a
list variable.

Tried doing it manually, still not go.

Then I had a look at making it work on Omnis 10.3, success.

I also noticed the following:-

$apiversion in Studio 6.3  version 9.1.1

$apiversion in Studio 10.3  version 9.5.5

Can this be fixed by changing DLL files or Xcomps.

A word of warning for new Postgres 14 users.

I wish Omnis would make a Linux version again as we are now seeing Chrome
using Debian operating systems.



Chris Hughes



Copious Data Pty Ltd (Trading as Atad Data)

3 Springwell Avenue

Springwood QLD 4127

Phone No:- 07 3208 6347

Mobile No:- 0409 263 349

Email:- ataddata at bigpond.net.au

Web Site:- http://ataddata.com.au





_____________________________________________________________
Manage your list subscriptions at https://lists.omnis-dev.com
Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 

 



More information about the omnisdev-en mailing list