AW: O$817 Win10 Printer Issue

Phil (OmnisList) phil at pgpotter.co.uk
Mon Jul 11 09:51:43 UTC 2022


Hey Rudolf,

I don't mind shameless guesses, especially if they resolve the issue...

I'll have a look, but that might take a while.

regards
Phil Potter
Based in Chester in the UK.

On 11/07/2022 10:42, Rudolf Bargholz wrote:
> Hi Phil,
>
> Perhaps you are missing an "End print" somewhere in your code. Some reports do not need this, others do, depending on how you program the reports. But this is just a shameless guess on my part.
>
> Regards
>
> Rudolf
>
> -----Ursprüngliche Nachricht-----
> Von: omnisdev-en<omnisdev-en-bounces at lists.omnis-dev.com>  Im Auftrag von Phil (OmnisList)
> Gesendet: Montag, 11. Juli 2022 11:38
> An:omnisdev-en at lists.omnis-dev.com
> Betreff: Re: O$817 Win10 Printer Issue
>
> Hi,
>
> I checked the code, and there is no use of a Begin print job...
>
> So thanks for the thoughts, but in this case it seems it is not the issue.
>
> Although what you are saying is, it is the code for that error?
>
> I guess internally it would still do that process, even for a single print, and whatever that is, is having an issue?
>
> regards
> Phil Potter
> Based in Chester in the UK.
>
>> Hi Phil,
>>
>> We too, like Simon, see this when a print job has been started with "Begin print job" but has not been ended with an "End print job", for whatever reason.
>>
>> You could try to issue an "End print job" prophylactically before starting a print process to see if this alleviates your problem. You would, in this case, need to override the E101288 error message using an error handler:
>>
>> Load error handler cErrorHandler/continueExecution (101288,101288) End
>> print job
>>
>> continueExecution:
>> SEA continue execution
>> Quit method kTrue
>>
>> If this resolves your issue, then you know that your issue has to do with the "Begin print job" .
>>
>> Regards
>>
>> Rudolf Bargholz
>> Hi,
>>
>> I got that message yesterday when I started a print job and then went
>> on to select the destination.
>>
>> Cheers
>>
>> Simon
> On 08/07/2022 14:49, Phil (OmnisList) wrote:
>> Hi,
>>
>> Anyone seen this issue before:
>>
>> "Cannot set report destination while a print job is in progress"
>> with a code of 101293
>>
>> Do you know what is the problem?
>>
>> Have a user getting this, occasionally...
>>
>> --
>> regards
>> Phil Potter
>> Based in Chester in the UK.
>>
>>
> _____________________________________________________________
> Manage your list subscriptions athttps://lists.omnis-dev.com  Start a new message ->mailto:omnisdev-en at lists.omnis-dev.com  
> _____________________________________________________________
> Manage your list subscriptions athttps://lists.omnis-dev.com
> Start a new message ->mailto:omnisdev-en at lists.omnis-dev.com  


More information about the omnisdev-en mailing list