Postgres says my password is invalid

Das Goravani goravanis at gmail.com
Sun Jan 30 20:42:22 UTC 2022


I want to thank Doug, Andy, Xavier, Alex.. and any others that chipped in, for helping me on this long thread.

I did ultimately get Postgres back up and running. I am able to log in from the server on localhost and a remote Mac using my public IP address as the destination IP.. so hba is good.. all is good. 

The trick that worked was to delete the postgres system user and reboot before installing again.

What happened I think is this: My first install, which went well at first, stopped working. In an effort to get it working I thought perhaps I should log into the server using that system Postgres user… and I tried to use it, but it refused my password. 

Confused, I logged in as my master user, and changed the password of that postgres user. I then logged into it, but it did not go well.

Thereafter postgres stopped working. Then this long thread ensued.

In the end I now know you don’t log into that user. I’ve been told. I also noted now that the postgres installer says it is creating a "Locked UNIX user" when it creates that account. So that user is off limits now, I get this. 

I think by allowing it to re-create that user, that that fixed things. I think changing it’s password was a no- no. 

I am up and running now. 

Previous to this thread was one where I was trying to get the COPY command to work.

It is now working, but it comes up with too many errors from my import file. I can’t use it. It is way too careful. 

So I am going to be importing the file with Omnis. I have another thread on here now about that. 

Thank you to you four for helping me here. I will save the exchange because there is a lot of useful terminal commands laced throughout it and other knowledge. 

Thank you very much,

Das Goravani




More information about the omnisdev-en mailing list