Postgres says my password is invalid

Das Goravani goravanis at gmail.com
Sun Jan 30 18:01:03 UTC 2022


On my server I have a user called “server” and Postgres installs a user called “PostgreSQL"

I’m talking main system users, what you log into when you first boot up a Mac.

I log into server always, I do everything from there.

I am doing this Postgres work from there.

This worked fine on the first installation of Postgres that I did a couple days ago. Being logged in as server was not a problem.

Today I tried to log into the PostgreSQL user, and had a myriad of problems.

First it said it didn’t have a keychain, and only option was to “Reset to defaults”. Being as I don’t know if the keychain is made on a per user basis, I did not opt to do this as I don’t want to lose everything in my server keychain.

Then when I cancelled on that window, I was supposedly “In the Finder”, but there was no menu bar, and things were stuck, could not click on the few things showing on the right side.. left side of menu bar, Apple etc., was missing.

Then did a keystroke to bring up the Force Quit list, and it said “Finder not responding”, so I relaunched it.

This did not help.. it continued to be missing the menu bar, could not do anything. 

Finally the menu bar appeared, tried to log out of that user, and the machine froze. Had to use the hard power switch to reboot the Mac Mini.

So my PostgreSQL user is messed up. It was created by the installer, and I have never logged into it til this attempt. 

I think I should delete it and reinstall Postgres. Let it create it again, and hope for better luck.

I was thinking of logging into that user and trying to run pgAdmin that way.. to see if anything was different, but I cannot effectively log into that user as it is. 


More information about the omnisdev-en mailing list