Apache caught SIGTERM?

Das Goravani goravanis at gmail.com
Sun Feb 27 21:22:14 UTC 2022



> On Feb 27, 2022, at 11:47 AM, Graham Stevens <graham.stevens at gmail.com> wrote:
> 
> Hi Das,
> 
> This might be a stupid question but are you sure you have View>All processes selected in Activity Monitor?
> 
> Apache spawns multiple processes automatically and will revive itself.  You need to find which one is running and disable its launch daemon.  Have you tried the command line:
> 
> apachectl stop

This helped. I went to Activity Monitor and found “Show all processes” and did that.. and then the HTTPD’s showed up sure enough.

I quit them all, and then did apachectl stop.. and then tried to launch my apache… it did NOT say that something was using the Ports this time, which is progress, and it took longer, to come back and say it could not launch. It wrote nothing to the log file. 

I then did sudo find -name httpd

And found an extra one in /usr/sbin/

Funny it did not find my real one yet

So there is another one. I tried to delete it but it would not let me. How do I find or know it’s “launch daemon”.. or how do I toss it if it won’t let me toss it. It must be a privileges thing. I’m logged in as the main user, normally having all privileges. I don’t fully get privileges however, or why some folders would be kept from the main user. I suppose /usr/sbin/ is quite a tightly controlled primary system folder.

How can I get rid of that apache.. I don’t want that one. I want only the one controlled by MAMP that is in it’s folder in Applications. 

That other apache was likely here all along as I did not recently install anything that would have included it. I wonder why it got activated at this time (If it did get activated somehow). It may be the source of all these extra httpd processes. 

OK it finally found the real one, it’s still searching, takes many minutes.. found the real one that I want

So so far I have two… the one I want and one extra one in /usr/sbin/ which will not let me trash it. 

And with apachectl stop I can now clear the message that something is using the ports but apache still won’t launch, still not writing to it’s error log since the entry that it caught SIGTERM which was yesterday

Seem to be making progress.. still baffled why it won’t start when I seemingly did nothing to change anything.. it was working for over a year flawlessly

It caught SIGTERM during a shut down, which I did to restart, to see if a certificate I just got from Certbot would work properly.. restarting to effect all changes but the only change was I was awarded a certificate, which I got by the normal method of:

Sudo certbot —apache -d <domain name> -d <www domain name>

Which is a really normal process.. and I don’t see why it should inspire changes in apache.. the —apache parameter is just to tell it that you’re running apache.. so that it knows what to do.. I suppose it writes to a config file, I suppose.. I don’t actually know what I’m talking about here. 

I’ve obtained certificates similar to this way before, rebooted, and not encountered any problems from it. But that was yesteryear. Today is problematic. 

Here’s one thought:  I used the word —apache, the parameter, when getting the certificate this time, I don’t think I used the word apache in the certbot command before. Does that try to write to apache.. maybe it does try to write to apache and maybe it writes to the one in the /usr/sbin/ directory.. maybe it doesn’t know about the MAMP PRO way of putting apache in Applications inside its own folder.. maybe Certbot is NOT MAMP Compatible in other words. Maybe it tried to write to the “other normal” apache and activated it, started it up, whereas before it was not running.. might explain why there are these other processes now. Maybe it elevated that apache in some way, putting down my real one in the MAMP folder… maybe my MAMP installation is now damaged somehow by the fact that I used the —apache parameter with certbot.

I don’t know what Im doing with Certbot. I searched the web for the syntax for how to get a new certificate as my multi domain certificate expired and I needed to get new ones.. I saw the —apache argument online and figured it must be a way of telling it you have apache.. are using apache… maybe that was a mistake. 

I have a good mind to restore my MAMP folder from before getting that certificate. But I’m scared of messing things up even more. 

Can you confirm my feeling that certificates or certbot, does not write to apache in any way.. I mean I have to tell my MAMP window where the new Certs ARE after I receive them.. seems like that’s the ONLY place that anything is written about the new certs. Seems I TELL apache where they are.. but then why the —apache parameter on the certbot command. 

Regards

Das Goravani


> 
> Rgds,
> Graham
> _____________________________________________________________
> Manage your list subscriptions at https://lists.omnis-dev.com
> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 



More information about the omnisdev-en mailing list