Apache caught SIGTERM?

Das Goravani goravanis at gmail.com
Sun Feb 27 00:10:02 UTC 2022


The Apache log file ends on an entry that it caught SIGTERM, and it gives the time of 15:32:41

That’s the last entry in it. I have tried to start Apache since then, but it has not made any entries in it’s log file since then.

Which is odd given I’ve tried to start it a number of times since then.

So I checked the system log for that time and it turns out that was right when I was shutting it down to restart it because I had updated one of my sites certificates, and had made changes to Apache to reflect it, so I thought I should restart … so it was shutting down when it caught SIGTERM.. it was right during the shutdown process. 

It was likely being told to shut down

If that inspires any thinking perhaps… 

It is now saying when I try to start Apache that something is using either port 80 or 443, which apache uses
Changing to other ports did not change that it will not start

I researched what is using port 80 at this time and was surprised to find 4 entries 3 of which were labeled as httpd, which I thought was apache itself.. and it says for those entries that they are listening on port 80

That surprised me. Because Apache is not running yet. Supposedly not running yet. 

I didn’t do anything lately that would install another version of Apache and set it up as a service that runs always.. I just put Postgres on this server, but since then have rebooted many times and apache would start just fine

The thing that changed right before I got news that it won’t start.. the reason I was rebooting is related to a new certificate for SSL for one of the sites Apache is hosting. I had just put in the path to the new certificate, into MAMP PRO, which puts it into Apache for you if it has to be put into Apache. I have used the file selection and thus path tool in MAMP PRO before with no problem.. meaning I pointed out certificates to it, in it’s own interface, before, and Apache would start thereafter. No problem. 

Its interesting that today I saw on one answer posted in some forum that Certbot can be the cause of Apache not starting up.. but the circumstance of that post did not seem to apply to my situation.. but it was possible, for certificate issues to stop apache from launching is one I took away from that. That is the activity I had just done in MAMP PRO which is Apache, then BAM, it caught SIGTERM.. 

I’m trying to join a forum but they take time to approve memberships for some reason they have. 

How do you stop Apache on the command line?

I’m thinking now that I should try stopping it, to see if its running, to see if I can start my real one thereafter. 

From the looks of it Apache is already running.. but I didn’t put another on the system, didn’t set up any services, didn’t install anything, except the certificate Certbot put on my system.. but I’m not aware anyways that certificates could stop apache, though I read it.. it’s more interesting that it says the port is in use.. that seems like a better lead

3 ID’s were HTTPD on the listing of “what is using port 80”

I don’t know how to file that response.. I cannot grock it as I think of httpd as apache, and how can there be 3 entries, me wonders

I don’t know which way to turn with this, except wait for that forum to be approved.. then ask there.. 

More information about the omnisdev-en mailing list