Postgres is going to sleep or something...

Das Goravani goravanis at gmail.com
Wed Feb 2 20:14:19 UTC 2022


Doug, I appreciate your long post about sleep in general, but...

It just happened so I took the opportunity to check all things.

I was connected to postgres on my MBP which is remote to the server. I had a SESSION showing under the SQL Browser in Omnis.

I then expanded the SQL Browser to see Tables within that session. There were none. There should be 1 there.

I figured my connection was dropped, or that "postgres went to sleep"

I tried to log on and got the watch on the logon command line in Omnis

I then switched to the server, tried to log Omnis in there. No go, got the watch. That now being a localhost connection attempt.

I then switched to pgAdmin on the server. I launched it. When in it I click on Servers and enter my password, I get the message that the connection attempt failed

If I then start postgres using Terminal

pgAdmin then connects just fine

And I can log Omnis in on both computers

And my one table shows in the SQL Browser in Omnis

It is really as if postgres is shutting down on the server all by itself

???


More information about the omnisdev-en mailing list