Omnis reports false erros when conneted to the odb server via wifi

Terence Young terry.young at journeymhc.org
Tue Aug 2 16:30:58 UTC 2022


Hi Andrew,

At the time we were getting the errors, we hadnot yet set app nap off.  we have since done that; however, I haven't heard back from the users.

This library uses a timer to ping the odb server to prevent their connection from being closed; I am not sure Omnis would have an opportunity to nap.

If I had to take a guess, I think the older engine does not handle the timer events on M1 computers; zt leat not when logging onto the server via wifi.

I have had the request to migrate our users to 10.2 31315 for some time now.  We deploy with jampf, the person in charge hasn't had the time to script the upgrade.

I think going to build 31315 is the only way to go; hopefully, it will resolve the problem.

terry




Terence J. Young, DC

System Administrator

IT

(608) 280-2679

________________________________
From: omnisdev-en <omnisdev-en-bounces at lists.omnis-dev.com> on behalf of Andrew McVeigh <surfway at bigpond.com>
Sent: Tuesday, August 2, 2022 1:58 AM
To: OmnisDev List - English <omnisdev-en at lists.omnis-dev.com>
Subject: Re: Omnis reports false erros when conneted to the odb server via wifi

CAUTION: This email originated from outside Journey. Please verify the sender before opening attachments or clicking links.


Have you set the AppNap for Omnis?

defaults write -app "/Applications/Omnis Studio Runtime 10.2 30204.app" NSAppSleepDisabled -bool YES

Replace 10.2 30204 with the version number you have installed

Andrew McVeigh
Surfway Real Solutions
Phone 02 44412679 Mobile 0418428016
www.surfway.com.au<http://www.surfway.com.au>
www.berrarabeach.com.au<http://www.berrarabeach.com.au>
 <http://www.surfway.com.au/>
> On 2 Aug 2022, at 5:12 am, Terence Young <terry.young at journeymhc.org> wrote:
>
> Hi,
>
> Omnis reports false errors when connected to the odb server via  wifi.  The library also uses a timer to make a connection (ping) to keep the connection alive.
>
> I don't see the problem with the 31315 build of omnis.  I am getting the errors from my users who are using the build of 10.2 before the 31315 build.
>
> I am unsure what is causing the problem.  Has anybody else seen something similar.
>
> I am wanting to install the 31315 build on my user's computers; however, I am getting pushback from my colleagues.
>
> The users are using M1 apple processors.
>
> terry
>
>
>
> Terence J. Young, DC
>
> System Administrator
>
> IT
>
> (608) 280-2679
>
> If you received this e-mail in error, please notify the sender, delete the e-mail, and do not use, disclose or store the information it contains. This e-mail and any attachments may contain confidential information, including records protected by WI Mental Health 51.30 and/or AODA federal confidentiality rules (42 CFR Part 2) - both prohibit you from making any further disclosure of this information unless further disclosure is expressly permitted by the written consent of the person to whom it pertains or as otherwise permitted by 51.30 or 42 CFR Part 2. A general authorization for the release of medical or other information is NOT sufficient for this purpose. Federal rules restrict any use of this information to criminally investigate or prosecute any alcohol or drug abuse client.
> _____________________________________________________________
> Manage your list subscriptions at https://lists.omnis-dev.com
> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com

_____________________________________________________________
Manage your list subscriptions at https://lists.omnis-dev.com
Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com


More information about the omnisdev-en mailing list