Studio 10.2 - HTTPClientWorker and OAUTH2Worker

malkishtini at malkishtini at
Fri Apr 1 18:51:54 UTC 2022

Hi Das,

Thank you for your email.
Actually, I contacted Omnis support about the error and they were kind enough to explain to me my problem.

This is my issue: the API that I was trying to consume is configured using IAM role and for that we need " AWS signature v4 " which is different from the oAuth2 authentication that is used in the OW3 HTTP worker example.
To consume an API that requires AWS signature v4,  we need to pass custom header that includes the authentication details for the API. This might be a bit tricky to do in Omnis (without an SDK), so we are re-thinking our solution and how can we bypass calling this API from Omnis.

I shared these details here in case there are helpful to others in the future.


-----Original Message-----
From: omnisdev-en <omnisdev-en-bounces at> On Behalf Of Das Goravani
Sent: Friday, April 01, 2022 11:12 AM
To: OmnisDev List - English <omnisdev-en at>
Subject: Re: Studio 10.2 - HTTPClientWorker and OAUTH2Worker


I don’t know the answer, over my head, but I wanted to offer that that error message sounds an awfully lot like it is from Omnis, and I wouldn’t be surprised if Omnis ASSUMES you always want an access token, that it assumes it and thus ends up requiring it to run. Pure suspicions, not knowledge. 


> On Mar 30, 2022, at 4:33 PM, malkishtini at wrote:
> Hello team,
> I have a new question today, it is about consuming an AWS REST API from Studio 10.2.
> This is my first time to use the HTTPClientWorker and OAUTH2Worker in Studio 10.2, that's why I want to make sure that I'm on the right track.
> My first attempt to connect to the REST API in AWS, when there is no authorization setup for the API, worked fine.
> My second attempt to connect to the same API, after enabling the AWS IAM authorization, failed with error " 13019 - The OAUTH2Worker object assigned to $oauth2 does not contain an access token".
> The API doesn't require a token for authorization, it only requires client access and secret access key which I'm passing to the API. So I wonder if this error is from Omnis or from the API??
> I'm able to connect to the API using postman with no issues (by only passing the client and secret access key).
> So before I dig more into this issue, I just wanted to see if anyone in this list was able to establish a successful connection from Studio 10.2/ Oauth2 to an API in AWS when the authorization is done using "AWS IAM" or that is not an option in studio 10.2 or..?
> BTW, I'm using the HTTPWorker sample in studio 10.2 to test the connection and I tried to change the authorization type, but I got the same error with the 3 types.
> It was suggested to me to read and use a signed URL for the request, but again, since I'm new to all this process, I wanted to check and confirm that I'm moving in the right direction.
> Thank you in advance for all feedbacks.
> Mayada
> _____________________________________________________________
> Manage your list subscriptions at Start a 
> new message -> mailto:omnisdev-en at

Manage your list subscriptions at Start a new message -> mailto:omnisdev-en at 

More information about the omnisdev-en mailing list