Conversion of Studio 6 to studio 10.2

Chris Hughes ataddata at bigpond.net.au
Fri May 28 01:11:33 UTC 2021


Hello one and all,

 

The current problem I have is when I open a window called WProfiles the
following happens.

 

The following 2 lots of code run this is without going into 'Edit or New
record stage, they execute and all you do is answer Ok twice, all then
becomes normal with window.

 

This is in an Omnis field number tab order 1.

 

On evAfter

If len(iFileRow.lg_user_name)<4

OK message Advice (Icon) {Password must 4 or more characters to a maximum of
20}

Queue set current field lg_user_name

Quit method 

End If

 

This is in an Omnis field number tab order 2.

 

On evAfter

If len(iFileRow.lg_pass_wd)<4

OK message Advice (Icon) {Password must 4 or more characters to a maximum of
12}

Queue set current field lg_pass_wd

Quit event handler (Discard event)

End If

 

 

Now here is the strange aspect, the above window functions as per design in
Windows 10 on 10.2 and in other previous lower versions, but not in
Macintosh 10.2  .

 

The user could probably live it.

 

I have these similar procedures embedded throughout the application they do
not appear to be causing any problems.

 

The Omnis bad fairies are at it again.

 

 

Chris Hughes

 

Copious Data Pty Ltd (Trading as Atad Data)

3 Springwell Avenue

Springwood QLD 4127

Phone No:- 07 3208 6347

Mobile No:- 0409 263 349

Email:- ataddata at bigpond.net.au

Web Site:- http://ataddata.com.au

 

 

 

 

 

 



More information about the omnisdev-en mailing list