Latest build v10.1 released (29237) problem dragging windows macOS

Doug Easterbrook doug at artsman.com
Tue Feb 23 15:20:37 UTC 2021


hi Xavier

for some more background:
- In development, we only use one library (other than the standard omnis ones)
- In runtime, we have a very small library that starts the main library.   the small library’s only job is to start the main library.

- The issue has been seen through all versions of 8.1, 10, 10.1 and 10.2 (osx only).
- I’ve seen in on high sierra and up
- we see the issue within the development and support staff 
- it happens for a specific window or anything derived from that window’s superclass, so I could pick any number of windows within the application to show it, but not all.
- most customers see it.

and…

the same behaviour does NOT occur when I create a new machine or VM and test on that.    



all of which makes me think it is an interaction with something else running or installed.     What, I don’t know.   thats why it is a devil to sort out.

I’m only going to assume that if Mike’s application does something similar, then it is an underlying thing, rather that the way we’ve coded or used omnis.

Maybe an external … although that wouldn’t make sense if it works on some machines and not others.


however, the problem has been there in the background since the migration to studio 8.   I just can’t pinpoint the correlating things ..  which I can usually do.



Doug Easterbrook
Arts Management Systems Ltd.
mailto:doug at artsman.com
http://www.artsman.com
Phone (403) 650-1978

> On February 22, 2021, at 11:01 PM, IT <it at plastipol.com> wrote:
> 
> Hi Doug,
> 
> I’m not able to reproduce this behavior under macos 10.13 and studio 10.1 build 29237. This makes me believe that this can be related to some omnis startup library that you are using. Could be ?
> 
> regards
> 
> xavier
> 
>> El 22 feb 2021, a las 19:53, Doug Easterbrook <doug at artsman.com> escribió:
>> 
>> hi Mike:
>> 
>> more of the mystery unravels.    
>> 
>> Are you saying you also have an issue where you end up having a big blank omnis window on top?   
>> 
>> and to further inquire about that, are the symptoms such that
>> 1) you opened a single window which is a real window
>> 2) then you do something in another application and come back to omnis
>> 3) and when you do … there is a white (or black) ghost window with nothing on it where you last had a window in omnis
>> 4) and the only way to get rid of that window is to open another one in omnis
>> 
>> 
>> if so, I can recreate this at will by:
>> 1) opening a single instance certain type of window  from our library that is a modless entry window (all other omnis windows must be closed
>> 2) clicking on any application to push the omnis window behind
>> 3) clicking the ‘closebox’ in the omnis window, even though it the not the front window
>> 4) the omnis window goes away
>> 5) then when you click on the omnis icon, and omnis comes to the forefront, you have the ‘ghost’ of the original window, in original size with title bar
>> 6) you cannot ever close this window — but it will go away if you open another window.
>> 
>> 
>> let me know.  I’d like to find out what the common cause is ..
>> 
>> if yours is similar to ours, I reported this with studio 8, 10 and 10.1 back in fall 2019, only OSX, and on high Sierra, maojave, catalina and big sur. 
>> 
>> All of our staff can recreate it on their machines.
>> 
>> 
>> I cannot create it on a brand new VM in parallels or a machine with nothing else on it.
>> 
>> 
>> which leads me to believe that there is some application interaction or something else I’ve got installed on our machine (like default folder, daylite, rocket chat or a myriad of other apps.).
>> 
>> 
>> anyway, very interested in hearing how you’ve seen this.
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> Doug Easterbrook
>> Arts Management Systems Ltd.
>> mailto:doug at artsman.com
>> http://www.artsman.com
>> Phone (403) 650-1978
>> 
>>> On February 22, 2021, at 10:12 AM, Mike Matthews - Omnis <omnis at lineal.co.uk> wrote:
>>> 
>>> Good question about RunTime.  No one has reported it yet, but I will make a point of asking this week, but maybe just a Dev thing.
>>> 
>>> I caught it doing the ‘I won’t budge for no one!’ issue today, as well as the Big Blank TopWin that isn't really there.  But when I see it, I can’t remember how to get it to do it again.  Bloody annoying really, as I want to get it solved.
>>> 
>>> Mike  
>>> 
>>> 
>>> 
>>>> On 22 Feb 2021, at 17:45, Doug Easterbrook <doug at artsman.com <mailto:doug at artsman.com>> wrote:
>>>> 
>>>> hi Mike.
>>>> 
>>>> good that you see a similar thing .  I haven’t seen it on the  10.2.28632 version, so its a new with the upcoming version thing.
>>>> 
>>>> are you also seeing in in runtime?
>>>> 
>>>> if so, it makes it a version of studio (10.1 and 10.2) that I think we may need to hold back from deployment.    It would cause a lot of support calls.
>>>> 
>>>> 
>>>> 
>>>> 
>>>> Doug Easterbrook
>>>> Arts Management Systems Ltd.
>>>> mailto:doug at artsman.com <mailto:doug at artsman.com>
>>>> http://www.artsman.com <http://www.artsman.com/>
>>>> Phone (403) 650-1978
>>>> 
>>>>> On February 22, 2021, at 8:08 AM, Mike Matthews - Omnis <omnis at lineal.co.uk <mailto:omnis at lineal.co.uk>> wrote:
>>>>> 
>>>>> This still happens in v10.2 (29096) on Catalina.
>>>>> 
>>>>> I can sort of reproduce it, and you are right, clicking back on the Finder, maybe then the Omnis dock icon, lets you continue.
>>>>> 
>>>>> Mike Matthews
>>>>> 
>>>>> Lineal Software Solutions
>>>>> Commercial House, The Strand<x-apple-data-detectors://1/1 <x-apple-data-detectors://1/1>> Barnstaple, Devon, EX31 1EU<x-apple-data-detectors://1/1 <x-apple-data-detectors://1/1>>
>>>>> 
>>>>> omnis at lineal.co.uk <mailto:omnis at lineal.co.uk><mailto:mike.matthews at lineal.co.uk <mailto:mike.matthews at lineal.co.uk>>
>>>>> 
>>>>> www.lineal.co.uk <http://www.lineal.co.uk/><http://www.lineal.co.uk/ <http://www.lineal.co.uk/>>
>>>>> 
>>>>> www.sqlworks.co.uk <http://www.sqlworks.co.uk/><http://www.sqlworks.co/ <http://www.sqlworks.co/>>
>>>>> 
>>>>> 
>>>>> 
>>>>> On 22 Feb 2021, at 15:57, Doug Easterbrook <doug at artsman.com <mailto:doug at artsman.com><mailto:doug at artsman.com <mailto:doug at artsman.com>>> wrote:
>>>>> 
>>>>> hi Xavier.
>>>>> 
>>>>> I wanted to weigh in that I’ve had problems dragging windows on 10.1.29237 installed since it was announced.    I’m on Catalina
>>>>> 
>>>>> my scenario might be different I’ve only got one library open (and all the omnis ones like VCS, etc)
>>>>> 
>>>>> I find that after editing code for a while and checking in/out ..    sooner or later, the windows will freeze.   I can edit code.   however all windows .. cannot be moved.
>>>>> 
>>>>> 
>>>>> Even if omnis is the ’top application and I see it in the OSX menu…
>>>>> 
>>>>> 
>>>>> I have to click on some other application (like finder window) … and then click on my omnis window in order to get to move my windows again.
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>>> Doug Easterbrook
>>>>> Arts Management Systems Ltd.
>>>>> mailto:doug at artsman.com <mailto:doug at artsman.com>
>>>>> http://www.artsman.com <http://www.artsman.com/>
>>>>> Phone (403) 650-1978
>>>>> 
>>>>> On February 18, 2021, at 1:48 AM, IT <it at plastipol.com> wrote:
>>>>> 
>>>>> Hi,
>>>>> 
>>>>> I’m having problems dragging windows with latest build of Omnis Studio 10.1 under macOS 10.14 and 10.13.
>>>>> 
>>>>> Anybody can confirm that latest build has or no has troubles dragging windows under macOS Mojave ?
>>>>> 
>>>>> 
>>>>> regards
>>>>> 
>>>>> xavier
>>>>> _____________________________________________________________
>>>>> Manage your list subscriptions at http://lists.omnis-dev.com
>>>>> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com
>>>>> 
>>>>> _____________________________________________________________
>>>>> Manage your list subscriptions at http://lists.omnis-dev.com
>>>>> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com
>>>>> 
>>>>> _____________________________________________________________
>>>>> Manage your list subscriptions at http://lists.omnis-dev.com
>>>>> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 
>>>> 
>>> 
>> 
>> _____________________________________________________________
>> Manage your list subscriptions at http://lists.omnis-dev.com
>> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 
> 
> _____________________________________________________________
> Manage your list subscriptions at http://lists.omnis-dev.com
> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 



More information about the omnisdev-en mailing list