Debugging Notarization

Das Goravani goravanis at gmail.com
Mon Aug 9 21:55:28 UTC 2021


I am further along on my notarization quest on my new user. 

Now I am able to get through the process. 

But it says “Invalid Package” as the result of my notarization. That is the feedback it gives me as to why it’s not notarized.

My final package is a DMG that includes a .pkg installer within it. This nested pkg installer is a fonts installer.  It only contains some fonts.

Previously I was able to notarize that fonts package on it’s own, then include it.

I tried not notarizing it and just notarizing my final dmg, but this gave the same message, Invalid Package (referring to my dmg)

I am using the same steps that have worked for me many times on another user account on my Mac. 

The one difference is that user is a Catalina Virtual Machine… running Catalina and Xcode 10

Whereas now I’m on BigSur and Xcode 12

When I notarize, it gives this error but it does not stop:  

CFURLRequestSetHTTPCookieStorageAcceptPolicy_block_invoke: no longer implemented and should not be called

It continues and finishes uploading, but then returns notarization did not take place. 

Any ideas?

Das


More information about the omnisdev-en mailing list