Omnis Data File issues

Thad Bogert thad at
Thu Apr 1 21:41:51 UTC 2021

Hi All,

I am experiencing a perplexing issue that I hope someone might be able to shed some light on.

We recently deployed an orphaned application that we converted from Studio 6 to Studio 10.2 so that the client could use the application on 64bit MacOS machines.

The converted application uses a two segment datafile that is being shared via ODB 1.75. 

The issue that we are experiencing is that when users with runtimes connect to the database, they are occasionally presented with the following errors:

•Bad file number passed to data manager.

•An error occurred locating a header record for a slot.

•Communication error on connection 

The interesting thing is that if I connect using the Studio SDK, the errors don’t occur. However, if I serialize that SDK as a runtime, the errors return.

The ODB is on an M1 Mac; which made me wonder if there might be compatibility issues.  But the same errors occur when it is shared from an Intel Mac. Almost all of the Macs are running Big Sur.

I have tried rebuilding the datafile, however it did not resolve the issue.

At this point, I am at a loss as to what could be causing the issue.  A similar configuration with Studio 6 and an ODB worked there for years without any issues.

My final thought is that there might be something network related. The client is going to try replacing the switch to see if it makes any difference.

Other than going on site and reviewing their configuration, does any have any thoughts as to what might be going on?  Omnis support has not been able to provide any insights into the issue.



More information about the omnisdev-en mailing list