Accessing a TLS1.2 web server from Omnis Studio 5 on Windows 10

Dik Langan DikLangan at
Thu Sep 17 05:47:53 EDT 2020

Hi All,

Doug came up trumps and got us sorted. The solution is relatively simple once you know how so just in case other people out there have the same issue here is the solution:

Install OpenSSL using the Win32OpenSSL-1_0_2o.exe (other versions may work for you but this is the one that worked for us - the next point is the critical one):
When installing Omnis Studio 5.2.x (dev or runtime) choose the options to allow the install to put some of the files in Windows/System32 (my apologies for not having the exact wording of that option)

We then found that TLS1.2 sites/services were accessible from the Omnis library.

Thanks again to Doug for his patience and guidance - very much appreciated!



From: Dik Langan
Sent: 14 September 2020 11:50
To: omnisdev-en at
Subject: Accessing a TLS1.2 web server from Omnis Studio 5 on Windows 10

Hi all,

On the Omnis forum I found a OmnisDev reply by Doug Easterbrook which appears to come close to answering the issue I have but having installed OpenSSL I am getting errors when trying to call a web service hosted on an HTTPS server using TLS 1.2 from my Omnis Studio 5 code on Windows 10 so I think I am missing something.

The reference conversation is here: "" and I have followed the steps (even tried installing the Win32 and Win64 versions of OpenSSL) and whilst the errors are different they all have the same cause by the look of it - I get:

WebDevGetSecureError = 3020:error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version:.\ssl\s23_clnt.c:658:


10084:error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version:.\ssl\s23_clnt.c:658:

with the obvious common message "SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version". Now as I know the server I am connecting to is running TLS 1.2 I wonder if there is some way to configure OpenSSL that I am missing as it appears to be trying just "TLS 1"?

If there is anyone out there with experience of getting Omnis 5 to talk to a server running TLS1.2 I would love some help please.



More information about the omnisdev-en mailing list