O$: v8.15 and connecting to PG

Mike Matthews omnis at lineal.co.uk
Tue Jun 12 11:55:42 EDT 2018


Hello All,

It was neither Phil's or Franco's suggestion. UK support told me to install this:
64-bit Microsoft Visual C++ Redistributable package for VS 2013
https://www.microsoft.com/en-gb/download/details.aspx?id=40784 <https://www.microsoft.com/en-gb/download/details.aspx?id=40784>
When I ran this, I can connect to the PG database from the Win10 machines, success!

Why we now have to install this at this point, I'm not sure, as Studio is now only a 64bit application.  We are moving all of our users to Windows10 and the 64bit version, in preparation for using Studio v8.1 of our application.  Maybe still some 32bit stuff hanging around possibly.

Good to have the answer, not sure if others are experiencing the same problem however.

Mike





Mike Matthews, Managing Director, Lineal Software Solutions Ltd

Apple Reseller, Microsoft Partner, SQLWorks Business Partner
phone: 01271 375999 | web: lineal.co.uk <http://www.lineal.co.uk/> | email: omnis at lineal.co.uk <mailto:mike.matthews at lineal.co.uk>
> On 12 Jun 2018, at 16:26, Franco Maregotto <franco.maregotto at icloud.com> wrote:
> 
> Ciao Mike!
> Are you maybe using SSH in a 64bit environment?
> 
>> Il giorno 12 giu 2018, alle ore 16:31, Phil (OmnisList) via omnisdev-en <omnisdev-en at lists.omnis-dev.com> ha scritto:
>> 
>> Hi Mike,
>> 
>> Maybe windows firewall is enabled, and you need to create an exception for port 5432?
>> 
>> regards
>> Phil Potter
>> Based in Chester in the UK.
>> 
>> On 12/06/2018 14:19, Mike Matthews via omnisdev-en wrote:
>>> Hello All,
>>> 
>>> I'm having trouble with new installs of v8.15 with Postgres and Windows 10 pro 64bit.  I can't make a connection to the PG database, but a Mac can.  So it's not a IP address issue.
>>> 
>>> These are new machines, with a new fresh install of Windows 10 pro 64bit.  Patched as well.
>>> 
>>> I install Omnis Studio 8.15 and try to make a connection to a known good working PG database.  I get the error message 'SQL Browser unable to log on: Client or interface function not available'.  I'm told this is to do with where libpq.dll is found, page 305 in the 'What's New PDF'.  I have only 2 copies of this file, 1 for Runtime folder, and the other in my dev copy of Studio.
>>> 
>>> I have had it working briefly, but can't figure what the real issue is and how to fix it.
>>> 
>>> What do others have to say about this please?
>>> 
>>> Thank you
>>> 
>>> Mike
>>> 
>>> 
>>> 
>>> 
>>> 
>>> Mike Matthews, Managing Director, Lineal Software Solutions Ltd
>>> 
>>> Apple Reseller, Microsoft Partner, SQLWorks Business Partner
>>> phone: 01271 375999 | web: lineal.co.uk <http://www.lineal.co.uk/> | email: omnis at lineal.co.uk <mailto:mike.matthews at lineal.co.uk>
>>> _____________________________________________________________
>>> Manage your list subscriptions at http://lists.omnis-dev.com
>>> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com
>>> 
>> _____________________________________________________________
>> Manage your list subscriptions at http://lists.omnis-dev.com
>> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 
> 
> _____________________________________________________________
> Manage your list subscriptions at http://lists.omnis-dev.com
> Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 




More information about the omnisdev-en mailing list