INSERT INTO in most generic forms just not working

Das Goravani das at
Sun Jan 28 21:53:41 EST 2018

I was trying to get a serial generator to work, I have had no luck. In the meanwhile, trying to get INSERT INTO to work, since that’s used typically as part of how you get a serial generator to work, has been frustrating.  I can’t get Insert Into to work at all, it stops on the following $prepare statement and beeps, and sits there with the error “unrecognized custom attribute”. 

I have gotten good enough at SQL and Omnis to know that I’ve tried the most generic ways of making it work and it’s still not. Fortunately a simple $insert command from the list still works.  

Everyone gave different methods for making it work, and I tried them all.  Spent all of Sunday on this.  In the end neither INSERT INTO or the serial generator are working. Neither.  Bummer.  It sounds like I’m dumb, but I’m not.  I know how to inspect examples given to me and glean out the methods therein and apply them.  I’m reading the Postgres and Omnis manuals for all parts of the syntax involved.  Beep. It just won’t prepare. 

Mind you other Statements and $prepare’s are working as normal.  I’m not doing anything different on this one.  I make sure the Window it’s in is live.  The list is both defined from a Schema and has it’s session object assigned.  I’ve been doing this some weeks and have never encountered the execution stopping on $prepare and beeping and being unwilling to go on.  Something is amiss but I can’t figure out what. 

Everyone’s examples beep.  Couldn’t process them.  Checked the quotes and brackets over and over, made and dropped my serial generator and default value over and over, through many permutations of code trying it every which way.  

Stuck.  I don’t expect to be saved from this exactly.  I know there’s much to consider.  I’m just writing out my frustration.  

More information about the omnisdev-en mailing list