Getting the value from nextval()

Das Goravani das at
Sun Jan 28 14:48:35 EST 2018

I am having a problem. It stops on $prepare() with unrecognized attribute.  I’ve tried everything. 

At this point I’m pretty sure I have a sequence generator as I got flags true on creating it, and then dropping it, and creating it again. 

All flags true on those things. 

Then I’ve made what I think is a correct INSERT INTO statement pasted here

Sta: {INSERT INTO customers VALUES (DEFAULT,@[$cinst.Cust_FirstName],@[$cinst.Cust_LastName],@[$cinst.Cust_eMail],@[$cinst.Cust_Phone],@[$cinst.Cust_Address1],@[$cinst.Cust_Address2],@[$cinst.Cust_City],@[$cinst.Cust_State],@[$cinst.Cust_Zip],@[$cinst.Cust_BalOwed],@[$cinst.Cust_BizName])  

Omnis’s own checking is stopping it. It’s not a false flag I’m getting, the Omnis execution stops on $prepare, beeps, and gives error unrecognized custom attribute

Since I’ve tried everything I know, I’m throwing this back up for help.

Oh yes, I have gotten flags true on setting the DEFAULT for that column

I’ve tried using DEFAULT in the values as shown above, and I’ve tried nextval (seq_cust_id)

Anyone see why Omnis is barking at this INSERT INTO command ?????

More information about the omnisdev-en mailing list