O$:5.2.3-MacOS 10.13.2 :: Drag and drop becomes impossible

Doug Easterbrook doug at artsman.com
Sat Jan 27 07:21:37 EST 2018

hi Jean -Marc

are you using Studio 5.2.3 on High Sierra?

I’ve seen this myself (a lot) .. since moving to high sierra.  I experience the same kind of conditions where
- cant reorder procedures vis drag drop
- cant change width of header lists
- can’t highlight text that easy.

I have NOT rebuilt the app or tried that to see if it works.

I have restarted the machine (used apple-R) to use disk utilities to scan the disk for errors.
I have tried things like preventing certain apps from running to see if there is an association
I have tried making sure omnis is the first thing I start

I’m at the point where I think it may even be the graphics card not liking one of my external monitors.    I have the 5K display from apple attached to my laptop and an old NEC multi sync where I typically keep my emails.     In the latest incarnation, I left the old NEC unplugged from my computer … and this past few days, Studio drag/drop works.

when drag/drop stops working — studio crashes quite often, usually when I think its about to invoke a timer procedure.

so, yes,   I’m experiencing a lot of developer pain since updating to High Sierra — It is frustrating.    I”m not entirely sure its Omnis Studio’s fault since mostly I’m blaming apple on this one (for making it harder to be a developer because of the consumer protections they stick into the OS, like app nap, gatekeeper, and all that crap).

I have seen that the same library, in studio 8.1.1 works just fine …   so — thats my goal.

Doug Easterbrook
Arts Management Systems Ltd.
mailto:doug at artsman.com
Phone (403) 650-1978

see you at the third annual users conference
https://tickets.proctors.org/TheatreManager/95/online?performance=29086 <https://tickets.proctors.org/TheatreManager/95/online?performance=29086>

> On Jan 27, 2018, at 3:15 AM, jmv <jmvoegeli at bluewin.ch> wrote:
> Dear Listers,
> I'm having a strange problem :
> It becomes impossible to drag and drop : either proprieties from te property manager or lines of code in the methods manager (to copy them, eg).
> Even in my own lists, it is no more possible to select multiple lines by dragging although it is still possible by shift click.
> I rebuild my app from «Omnis-Studio-5.2.3.app».
> Then drag and drop works again.
> But after a while ... it doesn't work any more.
> Has someone experiences such problem ?
> Thank You for your help.
> Best regards,
> Jean-Marc
> _____________________________________________________________
> Manage your list subscriptions at http://lists.omnis-dev.com

More information about the omnisdev-en mailing list