Export/Import from JSON

An an.bayens at justsoftware.be
Fri Jan 19 05:52:24 EST 2018



I downloaded the latest versions of the externals we use and it solved some issues.

Nu when I do the export I don't get any errors but the import still doesn't work.
I get the error : Unknown property in input JSON: currdaymode

	"ident": 1016,
	"order": 1,
	"objtype": "kComponent",
	"componentlib": "Calendar Library",
	"componentctrl": "Calendar Control",
	"properties": {
		"active": true,
		"allowchange": true,
		"alpha": 255,
		"candropcursor": 0,
		"contextmenu": "",
		"currday": {
			"type": 23,
			"data": "2004-01-01"
		"currdaycolor": "RGB(174,235,255)",
		"currdaymode": "kBorderNone",
		"currdaytextcolor": "RGB(0,51,102)",
		"cursor": 0,
		"daycolor": "RGB(255,255,255)",
		"dayfont": 3,
		"dayfontsize": 12,
		"daymode": "kBorderEmbossed",
		"daytooltips": true,
		"desgroup": 0,
		"designactive": true,
		"deslock": false,
		"disablefocus": false,
		"disablesystemfocus": false,
		"dragborder": false,
		"dragiconid": 0,
		"dragmode": "kNoDragging",
		"dragrange": "kRangeAll",
		"dropmode": "kAcceptNone",
		"edgefloat": "kEFrightBottom",
		"effect": "kBorderNone",
		"enabled": true,
		"fieldstyle": "",
		"firstday": "kMonday",
		"headingbold": true,
		"headingcolor": "RGB(204,204,255)",
		"headingfont": 3,
		"headingfontsize": 10,
		"headingmode": "kBorderEmbossed",
		"headingtextcolor": "kColorBtnText",
		"height": 192,
		"helpfile": 0,
		"keyevents": false,
		"left": 1,
		"monthtextcolor": "kColorBtnText",
		"mouseevents": false,
		"nodropcursor": 0,
		"objlink": 0,
		"otherdaycolor": "RGB(221,221,255)",
		"otherdaymode": "kBorderEmbossed",
		"othertextcolor": "kColorGrayText",
		"rmouseevents": false,
		"shortname": true,
		"showheading": true,
		"statusevents": false,
		"todaybold": true,
		"todayscolor": "RGB(204,204,255)",
		"todaystextcolor": "kBlue",
		"tooltip": "",
		"top": 26,
		"userinfo": "",
		"visible": true,
		"width": 226
Met vriendelijke groeten,
An Bayens
Product Manager

> Op 17 jan. 2018, om 15:16 heeft Phil (OmnisList) via omnisdev-en <omnisdev-en at lists.omnis-dev.com> het volgende geschreven:
> Hi An.,
> Just a quick comment, that I had this issue, just trying to recall which one it was...
> We had issues with some oWrite external properties, and this required a change from Michael to correct an internal issue...  (ST/AD/093)
> which he has now done, so that issue no longer remains with his later versions.
> Another issue I had, but has been resolved was with a line being greater than 255 characters long... (ST/AD/087)
> It seems a short line, so maybe a similar issue to oWrite is occuring with oWorkbook, but if its Excel, I'm not sure how you might correct it.
> Maybe Omnis support can confirm, and assist you with this.
> They like small libs which replicates the error, so if you can do this they will appreciate it, and find the problem quicker.
> regards
> Phil Potter
> Based in Chester in the UK.
> On 17/01/2018 13:40, An wrote:
>> Hi Alex,
>> I've added this to my .gitattributes.
>> I've then removed my local JSON export files and tried to do the export from scratch. The previous error is gone but now I get a different error:
>> Error code: 23470
>> Error Text: Invalid method line - tokenising and untokenizing the method line does not result in the same text: Do oWorkbook.$initialize(kXLxls)
>> Any experience with this error? I now have 176 errors like this?
>> Met vriendelijke groeten,
>> An Bayens
>> Product Manager
>>  Stationsstraat 266, B-1700 Dilbeek
>> T. +32 2 567 21 71
>> Helpdesk: +32 2 568 14 54
>> an.bayens at optimizegroup.be <mailto:an.bayens at optmizegroup.be>
>> www.justsoftware.be <http://www.justsoftware.be/> | www.optimizegroup.be <http://www.optimizegroup.be/>
>>  <http://www.justsoftware.be/>
>>    <http://www.justsoftware.be/> <http://www.justsoftware.be/nieuws/531-kmo-portefeuille> <https://www.facebook.com/optimizegroupBE> <https://www.linkedin.com/company/optimize-group> <https://www.linkedin.com/company/optimize-group> <https://twitter.com/groupoptimize> <https://plus.google.com/114613785888034261968> Follow us on your favorite social media sites! <https://plus.google.com/114613785888034261968>
>>> Op 17 jan. 2018, om 14:07 heeft Alex Clay <aclay at mac.com> het volgende geschreven:
>>> Hi An,
>>> Omnis is picky about the line endings in the .omh source files. It wants CR or CRLF. Git will natively use LF on a Mac, and pulling an external change might cause the line endings to change to LF.
>>> You can fix this by setting a .gitattributes file in your repository to specify CRLF line endings for omh file. I wrote up a guide on how to do this:
>>> http://omnis.ci/guides/sharing-omnis-libraries-on-github.html <http://omnis.ci/guides/sharing-omnis-libraries-on-github.html>
>>> Look under "Configure .gitattributes".
>>> I believe this is the cause of this error, but I might be wrong. Let us know if this fixes the problem.
>>> Alex
>>>> On Jan 17, 2018, at 05:26, An <an.bayens at justsoftware.be> wrote:
>>>> Hi all,
>>>> I'm trying to get the export/import from JSON to work but it doesn't go as well as I expected.
>>>> What I'm doing is I've opened my current library's of my project (11 library's) in Omnis 8.1.3. Then for each library I performed the action 'Export Lib to JSON'. That goes all very well and creates 11 folders on my mac. Then via SoureTree I did a commit and push to bitBucket. So far so good.
>>>> Then I created a branch in Sourcetree, I added a new window in my project in Omnis 8.1.3. Then I perform the action 'Update JSON Tree'. Then I see my changes in Sourcetree and I can commit & push these changes to bitBucket.
>>>> But then I changed some code (the title of my new window) directly in bitbucket en pulled these changes in to Sourcetree. That works as well but then I need to get those changes in Omnis Studio.
>>>> I tried to do the action 'Rebuild from JSON' but then all of a sudden I get all kinds of errors.
>>>> I get the message JSON Export completed with Errors:
>>>> Error code 23522
>>>> Error Text Error setting method text : [5].name (Unexpected error code:1)
>>>> Result: It deleted my current LBS on my mac. Then I tried to do it via the action 'New Lib from JSON' that gives the same errors?
>>>> Met vriendelijke groeten,
>>>> An Bayens
>>>> Product Manager
>>>> _____________________________________________________________
>>>> Manage your list subscriptions at http://lists.omnis-dev.com
>>> _____________________________________________________________
>>> Manage your list subscriptions at http://lists.omnis-dev.com
>> _____________________________________________________________
>> Manage your list subscriptions at http://lists.omnis-dev.com
> _____________________________________________________________
> Manage your list subscriptions at http://lists.omnis-dev.com

More information about the omnisdev-en mailing list