Export/Import from JSON

Graham Stevens graham.stevens at gmail.com
Wed Jan 17 08:48:57 EST 2018

Hi An,

As well as Alex's excellent advice, I'd just like to add a point 
concerning the deleted library.  If you need to get you're original 
back, Omnis should have archived it in the Application Support folder 
when you executed "Rebuild from JSON". Take a look in 
"~/Library/Application Support/Omnis/OmnisAppName/archives/"

And you may want to take a look at the exports.json file in 
"~/Library/Application Support/Omnis/OmnisAppName/studio/".  This is 
where Omnis records the paths to your previously exported libraries 
along with the paths to their export directories.  I have experienced 
occasional problems with Omnis writing invalid JSON out to this file 
which means the next time you start Omnis, it will not know where you 
exported your libraries for the "Update JSON tree" and "Rebuild from 
JSON" commands.  I have registered a support case on this and am hoping 
it will be fixed in 8.1.4

Good luck.

On 17/01/2018, An Bayens wrote:
> Hi all,
> I'm trying to get the export/import from JSON to work but it doesn't go as well as I expected.
> What I'm doing is I've opened my current library's of my project (11 library's) in Omnis 8.1.3. Then for each library I performed the action 'Export Lib to JSON'. That goes all very well and creates 11 folders on my mac. Then via SoureTree I did a commit and push to bitBucket. So far so good.
> Then I created a branch in Sourcetree, I added a new window in my project in Omnis 8.1.3. Then I perform the action 'Update JSON Tree'. Then I see my changes in Sourcetree and I can commit & push these changes to bitBucket.
> But then I changed some code (the title of my new window) directly in bitbucket en pulled these changes in to Sourcetree. That works as well but then I need to get those changes in Omnis Studio.
> I tried to do the action 'Rebuild from JSON' but then all of a sudden I get all kinds of errors.
> I get the message JSON Export completed with Errors:
> Error code 23522
> Error Text Error setting method text : [5].name (Unexpected error code:1)
> Result: It deleted my current LBS on my mac. Then I tried to do it via the action 'New Lib from JSON' that gives the same errors?
> Met vriendelijke groeten,
> An Bayens
> Product Manager

More information about the omnisdev-en mailing list