Export/Import from JSON

An an.bayens at justsoftware.be
Wed Jan 17 08:40:10 EST 2018

Hi Alex,

I've added this to my .gitattributes.
I've then removed my local JSON export files and tried to do the export from scratch. The previous error is gone but now I get a different error:
Error code: 23470
Error Text: Invalid method line - tokenising and untokenizing the method line does not result in the same text: Do oWorkbook.$initialize(kXLxls)

Any experience with this error? I now have 176 errors like this?

Met vriendelijke groeten,
An Bayens
Product Manager
Stationsstraat 266, B-1700 Dilbeek
T. +32 2 567 21 71
Helpdesk: +32 2 568 14 54

an.bayens at optimizegroup.be <mailto:an.bayens at optmizegroup.be>
www.justsoftware.be <http://www.justsoftware.be/> | www.optimizegroup.be <http://www.optimizegroup.be/>

 <http://www.justsoftware.be/> <http://www.justsoftware.be/nieuws/531-kmo-portefeuille> <https://www.facebook.com/optimizegroupBE> <https://www.linkedin.com/company/optimize-group> <https://www.linkedin.com/company/optimize-group> <https://twitter.com/groupoptimize> <https://plus.google.com/114613785888034261968> Follow us on your favorite social media sites! <https://plus.google.com/114613785888034261968>

> Op 17 jan. 2018, om 14:07 heeft Alex Clay <aclay at mac.com> het volgende geschreven:
> Hi An,
> Omnis is picky about the line endings in the .omh source files. It wants CR or CRLF. Git will natively use LF on a Mac, and pulling an external change might cause the line endings to change to LF.
> You can fix this by setting a .gitattributes file in your repository to specify CRLF line endings for omh file. I wrote up a guide on how to do this:
> http://omnis.ci/guides/sharing-omnis-libraries-on-github.html <http://omnis.ci/guides/sharing-omnis-libraries-on-github.html>
> Look under "Configure .gitattributes".
> I believe this is the cause of this error, but I might be wrong. Let us know if this fixes the problem.
> Alex
>> On Jan 17, 2018, at 05:26, An <an.bayens at justsoftware.be> wrote:
>> Hi all,
>> I'm trying to get the export/import from JSON to work but it doesn't go as well as I expected.
>> What I'm doing is I've opened my current library's of my project (11 library's) in Omnis 8.1.3. Then for each library I performed the action 'Export Lib to JSON'. That goes all very well and creates 11 folders on my mac. Then via SoureTree I did a commit and push to bitBucket. So far so good.
>> Then I created a branch in Sourcetree, I added a new window in my project in Omnis 8.1.3. Then I perform the action 'Update JSON Tree'. Then I see my changes in Sourcetree and I can commit & push these changes to bitBucket.
>> But then I changed some code (the title of my new window) directly in bitbucket en pulled these changes in to Sourcetree. That works as well but then I need to get those changes in Omnis Studio. 
>> I tried to do the action 'Rebuild from JSON' but then all of a sudden I get all kinds of errors.
>> I get the message JSON Export completed with Errors:
>> Error code 23522 
>> Error Text Error setting method text : [5].name (Unexpected error code:1)
>> Result: It deleted my current LBS on my mac. Then I tried to do it via the action 'New Lib from JSON' that gives the same errors?
>> Met vriendelijke groeten,
>> An Bayens
>> Product Manager
>> _____________________________________________________________
>> Manage your list subscriptions at http://lists.omnis-dev.com
> _____________________________________________________________
> Manage your list subscriptions at http://lists.omnis-dev.com

More information about the omnisdev-en mailing list