AdHoc Report library issue - help

Alan Schmidt alan at goconnected.com
Mon Apr 30 13:47:28 EDT 2018


Hi Vik,

Just wondering if you've had any luck finding a fix yet?

We'll be moving to Studio 8 soon and have many users still depending on the AdHoc lib so this will be an issue for us too.

-Alan


On 4/25/18, 4:22 PM, "omnisdev-en on behalf of Vik Shah" <omnisdev-en-bounces at lists.omnis-dev.com on behalf of Vik at Keys2Solutions.com.au> wrote:

    omnislist_members.$sendall(‘ hi! ’),
    
    I am trying to help a mate of mine out and I am stumped by as to why omnis studio 8.1.4 keeps crashing. Best ask the list for a second opinion. :-)
    
    Omnis Support has logged it as a bug ST/PF/1095, but there must be a work around that I am missing...
    
    To reproduce this, 
    1. Place the AdHoc library (yes, I know no one uses it anymore) into the Startup Folder of the omnis installation.
    2. you’ll need a data file open. I used one of the example/sample libs like Omnis DML entry for this.
    3. Create a New AdHoc report from a file class, any type/style and once past the wizard you’ll land on the report design window.
    4. Either press Ctrl+S or Command + S to save the report and omnis crashes! OR close the window and it will prompt you to save the report and omnis will crash.
    
    I think that its the nested calls to $canclose that are tripping over each other or its trying to close using a reference that is already dead.
    
    Just want to get a second opinion and perhaps an idea on how to fix this.
    
    Regards,
    
    Vik Shah
    Director
    Keys2Solutions
    AU: +61 411 493 495
    
    
    
    _____________________________________________________________
    Manage your list subscriptions at http://lists.omnis-dev.com
    Start a new message -> mailto:omnisdev-en at lists.omnis-dev.com 
    




More information about the omnisdev-en mailing list