Display picture

David Ferri davidferri at icloud.com
Thu Jan 26 18:18:24 EST 2017


Hi Doug,

We’re struggling with this as well. We have pictures stored in a SQL Server database that were most likely added by an Omnis 7 and/or Studio application with shared picture format turned on. Applying the pictformat() function returns a blank. We looked at the headers and nearly all of the pictures start with 00 04 which Kelly tells us he doesn’t recognize. In the old Omnis 7 documentation is states quite clearly that once set to shared picture format there is no going back. So where you say "you could use omnis to convert it from shared picture format to jpg or png” how would we do that?

Regards,
David Ferri, President
Word Master, Inc.
320 Earls Ct.
Deerfield, IL  60015
Ph: 847-948-9600
Cell: 847-922-0080
Fax: 847-948-9617
http://www.wordmaster.com <http://www.wordmaster.com/>
> On Jan 16, 2017, at 9:28, Doug Easterbrook <doug at artsman.com> wrote:
> 
> hi Dhulhum.
> 
> I suspect completely depends on the format you saved it in.   IF you viewed the picture in omnis — its probably in some omnis shared picture format and not the jpg or png thart you think it is.
> 
> if it is omnis shared picture format — then is compatible only with showing on omnis in mac or window — and there is no conversion (that I know of) that lets other applications use it natively.
> 
> but you could use omnis to convert it from shared picture format to jpg or png .. and then store that in the database — which might help you get it out with .net.
> 
> 
> thats my suspicion.       the omnis ‘pict’ commands such as pictconvto and pictformat might give you clues.
> 
> 
> 
> Doug Easterbrook
> Arts Management Systems Ltd.
> mailto:doug at artsman.com
> http://www.artsman.com
> Phone (403) 650-1978
> 
>> On Jan 16, 2017, at 7:20 AM, Dhulhum Khan <dhulhumkhan at gmail.com> wrote:
>> 
>> Hi all,
>> 
>> 
>> 
>> I have saved an image in oracle database from omnis studio application.
>> 
>> I have been given a task to fetch the same picture(BLOB) in .net
>> application which was saved to oracle database from omnis studio 5.2
>> application.
>> 
>> I am not able to display picture. It is giving invalid value error.
>> (ArgumentException (parameter is not valid) in .net application).
>> 
>> 
>> 
>> Can anyone help please.
>> 
>> 
>> 
>> Regards,
>> 
>> Dhulhum
>> _____________________________________________________________
>> Manage your list subscriptions at http://lists.omnis-dev.com
> 
> _____________________________________________________________
> Manage your list subscriptions at http://lists.omnis-dev.com




More information about the omnisdev-en mailing list