Sending mails with IMAP server

Lou Picciano loupicciano at comcast.net
Mon Jun 6 06:14:53 EDT 2016


A bit more precisely; not the HTTPS, but rather the STARTTLS bits of SMTP. 

Lou Picciano 

----- Original Message -----

From: "Mike Matthews" <omnis at lineal.co.uk> 
To: "OmnisDev List - English" <omnisdev-en at lists.omnis-dev.com> 
Sent: Monday, June 6, 2016 4:28:41 AM 
Subject: Re: Sending mails with IMAP server 

Ah, the Achilles Heel I'm afraid. In short, the answer is no if you want to use the Studio commands. 

Even with O$ v8, gMail is not easy to read, but with v5.2 and upwards, I think you can at least send via gMail and use SMTP however. All to do with the last param on the SMTPSend command, TLS, etc. 

I think there are ways, but involve HTTPS etc methods. 

Mike 


On 6 Jun 2016, at 09:21, Jean Marc Azerad <azerad.jm at wanadoo.fr> wrote: 

> Thanks Mike, 
> 
> But, I forgot to state, O$4 in that case. Would SMPTSendWork? 
> 
> I get -1212 undocumented error when trying with an IMAP Gmail account and imap.gmail.com as server or +10061 with a iCloud account and imap.mail.me.com as server. (just for testing purposes) 
> 
> What am’I missing? 
> 
> JM 
> 
> 
>> Le 6 juin 2016 à 10:07, Mike Matthews <omnis at lineal.co.uk> a écrit : 
>> 
>> Hello JM, 
>> 
>> You don't send via IMAP, still use the SMTP method. 
>> 
>> Use the IMAP to READ/MOVE/DELETE the mailboxes and the contents of the mailboxes, etc. TL have updated the IMAPListMessages command to help really speed the process of reading a mailbox contents: 
>> 
>> IMAPListMessages (lvSocket,pfMessageList,'getMailStsProc',lvIMAPResponseList,lvHeaderCols) Returns lvStatus ;; this will only work if the 5.2 patch is installed! 
>> 
>> Let me know if you need any more help. 
>> 
>> Thanks 
>> 
>> Mike 
>> 
>> 
>> 
>> 
>> 
>> 
>> Mike Matthews, 
>> Managing Director, SQLWorks Software Ltd 
>> 
>> Tel: +44 (0)1271 375999 
>> 
>> Email: mike.matthews at sqlworks.co.uk 
>> 
>> Web: www.sqlworks.co.uk 
>> 
>> Use SQLWorks, forget Sage, ACT!, Opera, Access & SAP 
>> 
>> On 6 Jun 2016, at 08:49, Jean Marc Azerad <azerad.jm at wanadoo.fr> wrote: 
>> 
>>> Good morning, 
>>> 
>>> I’ve used SMTPsend on regular basis to send email via a SMTP server. It just work and doesn’t require any knowledge or understanding from me and it’s fine! 
>>> 
>>> Now I need to send (and if possible receive) emails trough an IMAP server. 
>>> 
>>> Anyone can point for me the way to go? Extension? ActiveX? Automation control of Oultook? 
>>> 
>>> I’ve just no idea of where to start from. 
>>> 
>>> Many thanks 
>>> 
>>> 
>>> JM 
>>> _____________________________________________________________ 
>>> Manage your list subscriptions at http://lists.omnis-dev.com 
>> 
>> 
>> 
>> _____________________________________________________________ 
>> Manage your list subscriptions at http://lists.omnis-dev.com 
> 
> 
> _____________________________________________________________ 
> Manage your list subscriptions at http://lists.omnis-dev.com 



_____________________________________________________________ 
Manage your list subscriptions at http://lists.omnis-dev.com 




More information about the omnisdev-en mailing list