Webserver print to screen issue

Bruno Del Sol bruno.delsol at bydesign.fr
Sat Jun 4 17:14:00 EDT 2016


I've dropped the print control for pdfdevice a while ago so i have no real life win 2012 experience with it. Still, despite all the issues there is with win 2012 because of the new security restrictions, i don't see how it would touch the print control. 

My best guess here would be that you have printer driver issue. You should make sure you have a fairly reliable and generic default printer driver loaded with Win 2012. I use "Hp universal printing PS". Then in $construct of the reports do a $cinst.$pagesetupdata.$assign(#null) to wipe your development's pc printer setup



Envoyé de mon iPhone

> Le 4 juin 2016 à 22:38, <brian at revolution911.com> <brian at revolution911.com> a écrit :
> 
> Thanks Bruno,
> 
> I've been using the same procedures to print to screen using the binary and memory fields.   When I switched the server to Windows 2012, the print control doesn't work using the studio webserver version.   It does seem to work when I use the Studio Development version.   I don't understand why....but something on the Studio Webserver version is not working with the print control and Windows 2012.
> 
> -----Original Message-----
> From: omnisdev-en [mailto:omnisdev-en-bounces at lists.omnis-dev.com] On Behalf Of Bruno Del Sol
> Sent: Saturday, June 04, 2016 1:28 PM
> To: OmnisDev List - English
> Subject: Re: Webserver print to screen issue
> 
> Hum Brian, 
> 
> The Omnis server can print only to memory or file i'm afraid. So if you want to use the client's print control, you print to memory in a binary var server side, then you assign $reportdata of the rf print control to this binary for omnis to download it and display it on the client' screen. 
> 
> Hth
> Regards
> Bruno
> 
> Envoyé de mon iPhone
> 
>> Le 4 juin 2016 à 22:10, <brian at revolution911.com> <brian at revolution911.com> a écrit :
>> 
>> Does anyone know what Studio 4321 is using to print to screen if the
>> webserver is running on a windows server 2012 machine?   
>> 
>> 
>> 
>> I'm using a remote form with the print control placed on the remote 
>> form and it only shows a blank in runtime.
>> 
>> 
>> 
>> Is there a property that must be turned on in windows server 2012?
>> 
>> 
>> 
>> 
>> 
>> _____________________________________________________________
>> Manage your list subscriptions at http://lists.omnis-dev.com
> 
> 
> _____________________________________________________________
> Manage your list subscriptions at http://lists.omnis-dev.com
> 
> 
> _____________________________________________________________
> Manage your list subscriptions at http://lists.omnis-dev.com





More information about the omnisdev-en mailing list