SMTPSend problems on Mac

Gary Connor gary_connor at
Thu Dec 18 20:20:46 EST 2014

Gary is using 5.2.3. so there is no new information that would contradict
your reasoning.

Gary Connor, Ph.D., CIO
DirectLine Technologies, Inc.
1600 N Carpenter Rd  Ste D
Modesto, CA 95351

|-----Original Message-----
|From: omnisdev-en-bounces at [mailto:omnisdev-en-
|bounces at] On Behalf Of Michael Monschau
|Sent: Thursday, December 18, 2014 5:09 PM
|To: OmnisDev List - English
|Subject: Re: SMTPSend problems on Mac
|Hi Bob,
|A while ago I had such problems with Studio 6.0.x on Mac 10.7.5 on my
|I would get socket errors. When running the same code in Studio 5.2.2, no
|problem. What was interesting was, I figured out if I attempted to send the
|same email 12 times, I would get 11 socket errors, but it would always work
|the 12th iteration. Once it worked, I could continue to send e-mails as
long as I
|did not allow too much time to pass in between attempts. If Omnis became
|idle for some time, maybe ten minutes or more (not entirely sure about
|time), it would fail again for 11 times.
|I could never reproduce this on other machines, which also where running
|10.7.5. Now that I have upgraded to 10.10, the problem has gone away.
|I did report this to Tiger Logic (case CA05163) as my suspicion was that it
|caused by a change made to Studio 6 causing an intermittent problem with
|socket handling, but perhaps it goes back further than that. I never used
|only 5.2.2. Perhaps it was introduced in 5.2.3.
|My experience and your experience and that of Gary Conner suggest to me
|that there is some intermittent problem such as memory trampling or
|initialised variables with SMTPSend or socket handling. Would be
|to know what version of Studio Gary is using.
|Perhaps it would be an idea to report this to Tiger Logic.
|Michael Monschau (Director)
|Brainy Data Limited
|Reply To: michael at
|Phone: +44 (0)870 474 0708
|Web: the home of Omnis Components and Developer
|> On 18 Dec 2014, at 14:04, Bob Fiering <bob at> wrote:
|> Hi,
|> I have a customer with strange problems when trying to send mail in Omnis
|5.2.3 on OSX.
|> When entering the credentials for their account i got errors like
|> -1034 Connection time out. Sometimes even -10060 Socket error:
|Connection timed out
|> When entering gmail smtp settings settings
|<> with the user authentication settings, verify true
|and SSL true, everything is running fine.
|> But their own mail account (running at a web/mail server provider) gives
|> I tried to add portnumbers like 587 or 465 to their smtp server address
|no luck.
|> The same error -1034.
|> Anyone any idea.
|> I tried to use for their email account the gmail smtp server but then
|own email addess is replaced by the gmail address from the authentication
|when a customer gets the mail.
|> Anyone an idea what is happening here and how to solve it?
|> Thanks,
|> Manage your list subscriptions at
|Manage your list subscriptions at

More information about the omnisdev-en mailing list