SMTPSend problems on Mac

Michael Monschau michael at
Thu Dec 18 20:08:48 EST 2014

Hi Bob,

A while ago I had such problems with Studio 6.0.x on Mac 10.7.5 on my laptop. I would get socket errors. When running the same code in Studio 5.2.2, no problem. What was interesting was, I figured out if I attempted to send the same email 12 times, I would get 11 socket errors, but it would always work on the 12th iteration. Once it worked, I could continue to send e-mails as long as I did not allow too much time to pass in between attempts. If Omnis became idle for some time, maybe ten minutes or more (not entirely sure about exact time), it would fail again for 11 times.

I could never reproduce this on other machines, which also where running 10.7.5. Now that I have upgraded to 10.10, the problem has gone away.

I did report this to Tiger Logic (case CA05163) as my suspicion was that it was caused by a change made to Studio 6 causing an intermittent problem with socket handling, but perhaps it goes back further than that. I never used 5.2.3, only 5.2.2. Perhaps it was introduced in 5.2.3.

My experience and your experience and that of Gary Conner suggest to me that there is some intermittent problem such as memory trampling or initialised variables with SMTPSend or socket handling. Would be interesting to know what version of Studio Gary is using.

Perhaps it would be an idea to report this to Tiger Logic.


Michael Monschau (Director)
Brainy Data Limited

Reply To: michael at
Phone: +44 (0)870 474 0708
Web: the home of Omnis Components and Developer Services

> On 18 Dec 2014, at 14:04, Bob Fiering <bob at> wrote:
> Hi,
> I have a customer with strange problems when trying to send mail in Omnis 5.2.3 on OSX.
> When entering the credentials for their account i got errors like
> -1034 Connection time out. Sometimes even -10060 Socket error: Connection timed out
> When entering gmail smtp settings settings <> with the user authentication settings, verify true and SSL true, everything is running fine.
> But their own mail account (running at a web/mail server provider) gives problems.
> I tried to add portnumbers like 587 or 465 to their smtp server address but no luck.
> The same error -1034. 
> Anyone any idea.
> I tried to use for their email account the gmail smtp server but then their own email addess is replaced by the gmail address from the authentication when a customer gets the mail.
> Anyone an idea what is happening here and how to solve it?
> Thanks,
> Bob_____________________________________________________________
> Manage your list subscriptions at

More information about the omnisdev-en mailing list