Question on Creating ODBC DSN using Omnis 5.1.1 in Windows 7‏

Mayada Al-Kishtini mayada_encoda at hotmail.com
Mon Mar 11 13:25:27 EDT 2013


Hi All,

I have the following code that creates an ODBC DSN entry to connect to a SQL server db, it runs fine in “Windows 7 & Omnis 4.3”. But Omnis crashes when I ran the same code using “Omnis 5.1.1” (on the same machine as Omnis 4.3).

It crashes when it executes the “Do vODBCSession.$configDSN” line.

Do vList.$define(vKeyword,vValue)
Do vList.$add('DSN',vDSN)
Do vList.$add('Driver',vDriver)
Do vList.$add('Description',vHostName)
Do vList.$add('Server',vServer)
Do vList.$add('Database',vDatabase)
Do vList.$add('LastUser',vUserName)
Do vODBCSession.$configDSN(kODBCSystemDSN,kODBCAddDSN,'SQL Server',vList)

I tried using kODBCSystemDSN and kODBCUserDSN. Driver: 'SQL Server Native Client 10.0' and 'SQL Server', but no luck yet in getting the code to work in Omnis 5.1.1.

Any idea what could be causing this problem?

Thank you,
Mayada Al-Kishtini 		 	   		  



More information about the omnisdev-en mailing list