PostsreSQL / SQL newbie question (solved)

Bob Fiering bob at
Sun Apr 14 14:03:58 EDT 2013

Hi Mark,

Your email crossed the mail i was typing.
Problem solved.

Because the tables and fields i manually created worked in combination with Omnis and the tables Omnis created did not, i compared the syntax Omnis used and the one i used. 
There were quotes in the syntax for the tablenames and fields. I made an export file from the 'wrong' database and removed the quotes. After that i build the database with the right syntax and everything worked.

Thank you Mark, Bas and Andy for all your input.
If there are tips for working with Omnis in combination with Postgres please let me know.
Ofcourse i will be at euromnis again this year to learn some more.



Op 14 apr. 2013, om 09:29 heeft Bastiaan Olij <bastiaan at> het volgende geschreven:

Hi Bob,

Try changing the table name of the schema simply to 'FBV', omit the
public bit.

Also did you connect to the right database? With the postgres DAM you
select the database first, then logon, not the other way around, so you
may simply be connecting to the postgres database instead of your own

I need to find time to get my website back up and running but I'll send
you my old getting started demo library, you may find it of some use :)



On 14/04/13 4:28 AM, Bob Fiering wrote:
> Hi Mark,
> 1. Yes, i can connect with the Omnis SQL Browser to the postgres database. I can use show data and it shows the content of that table.
> I can also connect with the object in combination with my login window that i created. 
> 2. With the pgAdmin tool i can see all tables and its corresponding data. When moving all tables under Omnis the tables were automatic placed under Schemas / public / Tables. Under public also the sequences are placed.
> 3/4  I think here lies the problem. The monitor tool you mentioned (and i missed) gives the message
> 2013-04-13 19:51:40 CEST	ERROR	relation "public.fbv" does not exist at character 1269	
> 2013-04-13 19:51:40 CEST	STATEMENT	SELECT public.FBV.BBVCODE,   ......all fields from the table.....  public..FBV.BWEBSITE FROM public.FBV	
> when i choose show data in the SQL Browser of Omnis the statement is   SELECT * FROM "public"."FBV"
> So "public"."FBV" is the right syntax. When i look at the properties of the schema class the table name is public.FBV.
> When i change this to "public"."FBV" the error changes to
> 2013-04-13 20:08:16 CEST	ERROR	column FBV.bbvcode does not exist at character 8	
> 2013-04-13 20:08:16 CEST	STATEMENT	SELECT "public"."FBV".BBVCODE,"public"."FBV".BBVNAAM,  ..... all the fields from the table........  "public"."FBV".BWEBSITE FROM "public"."FBV"	
> So somehow the schema class i created by dragging the table to Omnis has not the right relation to the table in postgres.
> Not sure how to solve it, but i am a step further in the process of solving the problem.
> regards,
> Bob
> Op 13 apr. 2013, om 17:57 heeft Mark Phillips <mark.phillips at> het volgende geschreven:
> On Apr 13, 2013, at 8:22 AM, Bob Fiering wrote:

Manage your list subscriptions at

More information about the omnisdev-en mailing list